Brainware

Internet Solutions

Home  >  Knowledgebase

LDAP Import is too slow

Article ID:
BW835421978
Last Review:
18. 06. 2007

Find on this page


Symptoms

Importing accounts to the Columbus database via the LDAP import agent is much slower than in previous versions of Columbus.

Cause

Since Columbus 6.5 version the LDAP import agent attempts to detect IP and MAC addresses for computer accounts that should get added to the database. When machines are not online, the agent would take 10 to 20 seconds trying to connect to a computer to retrieve this information.

 

The information the agent is attempting to retrieve is helpful to avoid registering machines which MAC addresses that may have been stored in the AD database with different names. Such discrepancies would become visible when staging via PXE of using Wake-On-LAN support.

Resolution

If you do not want the LDAP import agent to retrieve this information, you can add the following registry entries in the registry of the machine where the Columbus infrastructure server is running:

 

HKEY_LOCAL_MACHINE\Software\Brainware\Columbus\6\LDAP Sync]

"RetrieveMACAddress"="0"

"RetrieveIPAddress"="0"

 

 

Note: You should be aware that filtering this information might result in duplicate machines MAC or IP addresses added to the database.

 

Related Articles

Keywords:

LDAP, Import, Migration, Active Directory